6 Replies Latest reply: Apr 18, 2013 3:02 AM by chm RSS

Issues using Firepro V3750 and V4800

allforum Newbie
Currently Being Moderated

Hello,

 

I already posted here :

http://devgurus.amd.com/message/1288255#1288255

 

I have no problem with nvidia.

Catalyst 13.3 beta 3 seems to solve the problems on HD5450 (confirmed)

Firepro V4800 : the last driver solves some things but not all

Firepro V3750 : no update since 23/05/2012 !!


Any explanations or workarounds from AMD people ?

  • Re: Issues using Firepro V3750 and V4800
    chm Moderator
    Currently Being Moderated

    Hi,

     

    I tried to reproduce the issue with the vertex shader that you attached to your post to: http://devgurus.amd.com/message/1288255#1288255

    Using the 9.003.3 driver the vertex shader seem to run fine. I did a quick test using this shader with some stippled line drawing (in a DisplayList) and could not reproduce a crash.

    Do you have a sample available that we can use  to reproduce the issue you see when using the 9.003.3 driver?

     

    The V3750 is no longer supported in the latest drivers but only maintained in the 8.911.3.4 branch. Still bugs will be fixed in this branch. If you detect bugs with the V3750 the best is to report them to http://emailcustomercare.amd.com/

    The information presented in this document is for informational purposes only and may contain technical inaccuracies, omissions and typographical errors. Links to third party sites are for convenience only, and no endorsement is implied.
    • Re: Issues using Firepro V3750 and V4800
      allforum Newbie
      Currently Being Moderated

      Hello,

       

      Thanks for your test.

      Unfortunatly I have no simple code to reproduce...

      I join the full shaders (a simple phong vertex + fragment shader - source1.cpp)

      I also joined the pixel format in my other post (http://devgurus.amd.com/message/1288255#1288255) because without MSAA the things are often better.

       

      The last driver corrects the drawing of the views on Firepro V4800.

      Do you see something that was corrected between driver 9.3.3.0 (20/11/2012) and the last 9.3.3.3000 (6/2/2013) that is related to my problems ? Maybe this can give an idea where to search...

       

      I also join a version of my function (source3.cpp) ; it was tested with HD5450.

      It does not work with driver 13.3 beta 2.

      It works with driver 13.3 beta 3.

      Do you see something that changes between beta 2 and beta 3 than can be interesting for me ?

       

      I don't know where to search and I am not sure that the problems come from our code : some issues where corrected by upgrading the drivers and we have no problem with nvidia cards...

       

      Thanks

      • Re: Issues using Firepro V3750 and V4800
        allforum Newbie
        Currently Being Moderated

        Hello,

         

        There is no more crash with stipple lines on V4800 : the problem was in the data of my colleague...

         

        There is still the initial problem of function call with the shaders that I joined on HD 5450,  V4800 and V3750.

         

        There are problems with stipple lines with thick lines (glLineWidth(3) or glLineWidth(5)) on V3750.

        Here is the code we use :

        glLineStipple(1, -1); // plain

        glLineStipple(1, -8323200); // stipple

        glLineStipple(1, -2004318072); // stipple

        When we create AND modify an object a new display list is created (on modify the old list is deleted or stored in an undo/redo list).

        I hope these details will enable to reproduce.

        There is no crash but some lines are not drawn, or a line is drawn with the bad stipple, or changing one line stipple changes the other lines with the same stipple. It has no sense.

         

        The problem exists :

        - with shaders (posted in previous message) and MSAA.

         

        No problem :

        - with shaders and no MSAA.

        - without shaders and MSAA.

        - without shaders and without MSAA.

         

        With the same executable and the same test there is no problem with HD5450 and V4800.

        • Re: Issues using Firepro V3750 and V4800
          chm Moderator
          Currently Being Moderated

          Hi,

          I will try to reproduce and let you know.

          You mentioned that the 13.3 Beta 3 driver works better. Are all problems resolved using this driver? If so the next Workstation driver will most likely contain all fixes you need.

          The information presented in this document is for informational purposes only and may contain technical inaccuracies, omissions and typographical errors. Links to third party sites are for convenience only, and no endorsement is implied.
          • Re: Issues using Firepro V3750 and V4800
            allforum Newbie
            Currently Being Moderated

            Hello,

             

            Driver 13.3 Beta 3 does not concern Firepro cards.

            On HD 5450 the function in source3.cpp does not work with driver 13.3 beta 2 but works with driver 13.3 beta 3. What changed ?

            But in the full shaders (source1.cpp) I have found that if I move variables L and R from the fragment shader to the vertex shader and send them to the fragment shader using varyings then I have again the problem. (In my case with a directionnal light L and R may be in the vertex shader...)

            So there is a problem... and maybe not only with the function call.

             

            I took your advice and report the bug with stipple lines on Firepro V3750.

            Is it possible to add informations using the ticket number ?

             

            On my soft I can now reproduce a line that disappears when changing the stipple of another. Not with all kind off stipples...

            When I select a line to change the stipple a selection manager highlights the line using opengl. I don't know this code ; I have to look at it.

            If you want I can give you the steps to reproduce but without informations on the selection manager...

            • Re: Issues using Firepro V3750 and V4800
              chm Moderator
              Currently Being Moderated

              Hi,

               

              sorry for the delay. I continued trying to reproduce the issue using the same pixel format as you but still I did not see the issue with the line stipple..

              It would be really useful to get a reproducer, then we can check what is going wrong. if you do not want to post your application to the forum you can open a ticket for this issue as well. If you provide the ticket number I can get the app and have a look.

              The information presented in this document is for informational purposes only and may contain technical inaccuracies, omissions and typographical errors. Links to third party sites are for convenience only, and no endorsement is implied.

More Like This

Legend

  • Correct Answers - 4 points
  • Helpful Answers - 2 points